2015年2月13日

MyJVNバージョンチェッカがJava不要に

インストールされたソフトウェアが最新版に更新されているかどうかチェックするMyJVNバージョンチェッカが新しくなった。以前はJavaがインストールされていないと実行できなかったが、新しいバージョンは.netで動くのでJava不要だ。

Javaはすっかり使われなくなったので、よほどのことがない限りインストールしたくない。脆弱性のチェックのためにセキュリティリスクの高いJavaをインストールするというのは本末転倒だっただけにこの改善はありがたい。

ウィンドウズには基本的に入っているとはいえ.NET Framework 3.0 SP2 / 3.5 SP1が必須という点は改善が必要だろう。できることならば単独の実行ファイルで脆弱性がチェックできるようにしてほしいところだ。

http://jvndb.jvn.jp/apis/myjvn/vccheckdotnet.html